OFSA Upgrade Errors on OFSA_IDENTITY_SEQ

(Doc ID 331437.1)

Last updated on JANUARY 24, 2008

Applies to:

Oracle Financial Services Applications (OFSA) - Version: 4.5
Oracle Financial Data Manager - Version: 4.5.39
This problem can occur on any platform.

Symptoms

When attempting to upgrade to 4.5.39, the following errors were found in the patch 4.5.38 upgrade logs:

***********************************************************************

2374685 -- Create new sequence OFSA_IDENTITY_SEQ
***********************************************************************
ofsa_util.get_identity_code('P4536', 'ledger_stat', FALSE);
    *
ERROR at line 9:
ORA-06550: line 9, column 7:
PLS-00306: wrong number or types of arguments in call to 'GET_IDENTITY_CODE'
ORA-06550: line 8, column 4:
PL/SQL: Statement ignored

GRANT SELECT ON ofsa_identity_seq TO ofdm_r_bc
                            *
ERROR at line 1:
ORA-00980: synonym translation is no longer valid

GRANT SELECT ON ofsa_identity_seq TO ofdm_r_di                            * ERROR at line 1: ORA-00980: synonym translation is no longer valid

************************************************ 2093632 -- Fix OFSA_UTIL.SYNCHRONIZE_INSTRUMENT ************************************************     -- OFSA_UTIL     Package created.     No errors.     Warning: Package Body created with compilation errors.     Errors for PACKAGE BODY OFSA_UTIL: 2831/7  PL/SQL: SQL Statement ignored 2831/14 PL/SQL: ORA-02289: sequence does not exist

Changes

Upgrade to OFSA 4.5.39.

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms