Cannot Start Psub After Upgrading To OC 4.5.1 (Doc ID 344373.1)

Last updated on DECEMBER 21, 2009

Applies to:

Oracle Clinical - Version: 4.5.1
Information in this document applies to any platform.

Symptoms

On 4.5.1 in Production:
Upgraded Clinical Server to 4.5.1.
Cannot start PSUB on UNIX backend server connected as rxcprod.
/u01/opapps/bin/start_psub: %oui_opa_bin%/check_opa_settings.sh: not found
File opa_settings contains errors, described above, that will prevent opa_setup from working
correctly

The apply_opa_oc_server_unix_oc4.5.1.log contains numerous archive errors:

Inserting oclnlslx.o into archive /uo1/opapps/oc/45/common/nlslib.a
ERROR: Replacement of oclnlslx.o in archive
/uo1/opapps/oc/45/common/nlslib.a failed.
Halting processing of this file...
+++ Outcome for common/oclnlslx.o: FAILURE
.
.

The link_opa_oc_server_unix_oc4.5.1.log has numerous linking errors:

+++ Processing common/rxccossf ...
Linking rxccossf ...
ERROR: Link of rxccossf returned non-zero status 127.
Halting processing of this file.

+++ Outcome for linking rxccossf: FAILURE
.
.

The issue can be reproduced at will with the following steps.

EXPECTED BEHAVIOR
Expect PSUB to start after upgrade.

STEPS
start_psub ocdev01 45 as rxcprod

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms