How To Hardcode P6 Web Access To Use A Specific Java Runtime Environment (JRE) Version When Running Applets

(Doc ID 899568.1)

Last updated on MARCH 26, 2018

Applies to:

Primavera P6 Enterprise Project Portfolio Management - Version 6.0 and later
Primavera P6 Enterprise Project Portfolio Management Cloud Service - Version 8.4.0.0 and later
All Platforms

Goal

The goal of this document is to provide instruction for reconfiguring P6 Web Access to use a specific JRE version from its default version for usage when loading applets.

Applets are areas in the P6 application which load using a JRE, such as Projects/EPS Applet, Activities Applet, User Access Applet, Dictionaries Applet, Resource Management Applet, Resource Assignments Applet.  This document is specific for hardcoding these areas to use a specific JRE from the default

When the following two conditions are met, the browser and JRE applets will use the higher JRE and disregard the configuration settings which will be discussed within this document.  For this instruction to work when this condition exists, the JRE for which the application is being configured with must currently exist:
  1. The JRE which is being configured *is not* currently installed.
  2. A JRE version higher than the version for which to be configured *is* installed.

For example:
  • If you are attempting to configure the application to use a lower JRE version (JRE 1.6.0_14) than what is currently installed on a user's workstation (JRE 1.6.0_24), loading an applet within P6 will not prompt to download and use 1.6.0_14 automatically.  JRE 1.6.0_14 will have to manually be installed prior to following this instruction."
  • This is *not* the case if a JRE *lower* than what is being configured with Web Access is currently installed.

Solution

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms