No Messages From ASAP To Managed Weblogic Server When Located On Different Nodes (Doc ID 948287.1)

Last updated on AUGUST 04, 2013

Applies to:

Oracle Communications ASAP - Version 5.2.4 and later
Information in this document applies to any platform.
***Checked for Currency on 04-Aug-2013***

Symptoms


In this note the following configuration is covered: WebLogic 9.2 (Admin + Managed servers) and ASAP5.2.4 GA, with a High Availability (HA) solution (SUN + Veritas).  All installation configurations have been edited to have virtual IPs; one for the admin server, one for the managed server, and one for ASAP.

Admin and Managed WebLogic servers are on the same physical machine, but on different virtual IPs.
When the WebLogic components are located on a different physical machine than ASAP, the
createOrderByValueRequest somehow makes it to ASAP, the createOrderByValueResponse is sent to the
XVTTopic, and although processing completes in ASAP the orderCreateEvent, orderStartupEvent, and
orderCompleteEvents are not sent to the XVTTopic until the Web Logic components are switched back to
reside on the same physical machine as ASAP. Snoops show no comms from Web Logic to the Daemon server, but there does seem to be comms directly to the SARM. From the ASAP side there seems to be no direct comms with the Managed server IP.


Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms