My Oracle Support Banner

PPM API's Not Working After New Server Installation of PPM 7.5 SP2, Error 401 (Doc ID 987701.1)

Last updated on NOVEMBER 26, 2019

Applies to:

Primavera Portfolio Management - Version 7.5SP1 and later
Information in this document applies to any platform.
Checked for relevance on 07-Oct-2013

Symptoms

Following a new PPM server installation (server refresh), The PPM open API is not working. The following error message is produced when attempting to login using the open API:

Error Message when logging in to open API:

Error encounted during login. The request failed with HTTP status 401: Unauthorized.System.Web.Services at System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream,Bolean asyncCall)
at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters)

When viewing to check to see if the services are working - http://SERVER_NAME/ProSightSOAP/psPortfoliosInfo.asmx, the following error is produced:

Error Message when attempting to check services:
The page cannot be displayed
You have attempted to execute a CGI, ISAPI, or other executable program from a directory that does not allow programs to be executed.
--------------------------------------------------------------------------------
Please try the following:

Contact the Web site administrator if you believe this directory should allow execute access.
HTTP Error 403.1 - Forbidden: Execute access is denied.
Internet Information Services (IIS)

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Cause
Solution


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.