ICS Unable To Activate Integration With Mapping Component Error - Invalid Map Extensions Exist

(Doc ID 2307208.1)

Last updated on SEPTEMBER 20, 2017

Applies to:

Integration Cloud Service - Version 16.4.1 and later
Information in this document applies to any platform.

Symptoms

ACTUAL BEHAVIOR
---------------
ICS Unable to Activate Integration with Mapping Component Error - Invalid Map extensions exist. See below for the the error:



Using a non-standard (date conversion) XSLT functions in the ICS mapping component. This has introduced a date conversion function in JDEV.

In 17.1.3 importing this XSLT back into ICS meant that is no longer editable in the mapping component via ICS. However editing all other components via ICS and re-activate the integration are doable.

Since the 17.2.5 upgrade, the mapping component shows error 'Invalid Map extensions exist'. In addition to this, a validation has been introduced that prevents activation of any integration with an error. Due to these two factors it is not possible to activate any integrations once edit is selected.

Workaround:
- Make change in ICS Integration (applicable if the change is for any element apart from the mapping component)
- Export ICS Integration IAR
- Regenerate the ICS Map activity and merge into new XSL. If a mapping component change is required it is done here via JDEV.
- Import ICS Integration IAR


EXPECTED BEHAVIOR
-----------------------
These mappings should work in 17.2.5


Changes

 

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms