Asset Created Successfully In Account Through SOAP Web Services But Is Not Displayed In The SUI

(Doc ID 2340559.1)

Last updated on DECEMBER 18, 2017

Applies to:

Oracle Fusion Sales Cloud Service - Version 11.12.1.0.0 and later
Information in this document applies to any platform.

Symptoms

On : 11.12.1.0.0 version, Accounts, Contacts, Households

ACTUAL BEHAVIOR
---------------
Problem when creating Asset in Account through WEB Services SOAP

Using https://<pod>/crmCommonSalesParties/SalesAccountsService?WSDL and the mergeSalesAccount method to create an asset under an account.
In the response user gets the asset id and all the asset information which means the asset was created.
But when going to the UI or using the method GetSalesAccount to retrieve the account information the user does not see/get any asset associated to the account

 

EXPECTED BEHAVIOR
-----------------------
The account should have the asset associated to it

STEPS
-----------------------
The issue can be reproduced at will with the following steps:
1. Use the mergeSalesAccount operation from the SalesAccountsService WS 


BUSINESS IMPACT
-----------------------
The issue has the following business impact:
Due to this issue, users cannot create assets under accounts using web services

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms