My Oracle Support Banner

Unable To Configure General Ledger (GL) Segments Due To Error 'The Segment Identifier Class Is Not Valid. (FND-2567)' (Doc ID 2360182.1)

Last updated on OCTOBER 06, 2020

Applies to:

Oracle Fusion Global Payroll Cloud Service - Version 11.13.17.11.0 and later
Oracle Fusion Global Payroll - Version 11.12.1.0.0 and later
Information in this document applies to any platform.

Symptoms

ACTUAL BEHAVIOR
--------------------------
While attempting to Create Key Flexfields after entering Segment Code and API Name the below error is received:

- "The segment identifier class is not valid. (FND-2567)
 In application 801, key flexfield COST, structure CHO, and segment Class, the segment identifier must begin with an English letter which may be followed by letters or digits."

- Segment Code: "The segment identifier class is not valid. (FND-2567)
 In application 801, key flexfield COST, structure CHO, and segment Class, the segment identifier must begin with an English letter which may be followed by letters or digits."

- API NAME: "The segment identifier class is not valid. (FND-2567)
 In application 801, key flexfield COST, structure CHO, and segment Class, the segment identifier must begin with an English letter which may be followed by letters or digits."

EXPECTED BEHAVIOR
-------------------
Able to create flexfields with the current combination


STEPS
-----------------------
The issue can be reproduced at will with the following steps:
1. Manage Cost Allocation Key Flexfield - Create - Add Segment - Save
2. Error occurs

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Cause
Solution
References


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.