My Oracle Support Banner

[OCI]: Applying Database System Patch Fails With Error "Found unsupported DCS Agent version" or "current agent version is less than min version" (Doc ID 2473667.1)

Last updated on JUNE 22, 2020

Applies to:

Oracle Cloud Infrastructure - Database Service - Version N/A and later
Information in this document applies to any platform.

Symptoms

Applying database system patch from OCI console failed with one of the following errors:
"DCS-10001:Internal error encountered: current agent version is less than min version 18.1.3.0.0 please update agent first."

"DCS-10205:Operation: Patch update failed, Found unsupported DCS Agent version: 18.3.3.0.0, Expected version: 18.3.4.0.0"

Output of describe job as below:
=====================
[root@hostanme-18c bin]# dbcli describe-job -i 3cffd032-bfc3-44e9-9259-da73f810e687

Job details
----------------------------------------------------------------
ID: 3cffd032-bfc3-44e9-9259-da73f810e687
Description: Server Patching
Status: Failure
Created: October 5, 2018 4:38:00 AM UTC
Message: DCS-10001:Internal error encountered: current agent version is less than min version 18.1.3.0.0 please update agent first.

Task Name Start Time End Time Status
---------------------------------------- ----------------------------------- ----------------------------------- ----------
Server Patching October 5, 2018 4:38:00 AM UTC October 5, 2018 4:38:01 AM UTC Failure
Create Patching Repository Directories October 5, 2018 4:38:00 AM UTC October 5, 2018 4:38:00 AM UTC Success
Download latest patch metadata October 5, 2018 4:38:00 AM UTC October 5, 2018 4:38:01 AM UTC Success
task:TaskParallel_1028 October 5, 2018 4:38:01 AM UTC October 5, 2018 4:38:01 AM UTC Failure
minimum DcsAgent version checking October 5, 2018 4:38:01 AM UTC October 5, 2018 4:38:01 AM UTC Failure
=====================

===================
ID: 59ca6634-3d64-4259-89a8-3f115697f28c
Description: Server Patching Prechecks
Status: Failure
Created: June 12, 2019 3:32:50 AM UTC
Message: DCS-10205:Operation: Patch update failed, Found unsupported DCS Agent version: 18.3.3.0.0, Expected version: 18.3.4.0.0
=====================

==================
ID: cc5ede0f-8fe4-4e57-a20f-be71963c6e6d
Description: Server Patching Prechecks
Status: Failure
Created: June 19, 2020 11:05:53 AM UTC
Message: DCS-10205:Operation: Patch update failed,
Found unsupported DCS Agent version: 19.4.3.2.0,
Expected version: 20.1.2.0.0
==================

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Cause
Solution


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.