My Oracle Support Banner

Output "M�" on Create Message On Service Request Via REST API (Doc ID 2487001.1)

Last updated on DECEMBER 22, 2020

Applies to:

Oracle Fusion Engagement Cloud Service - Version 11.13.18.05.0 and later
Information in this document applies to any platform.

Goal

On : 11.13.18.05.0 version, Service Requests


Customer was creating message on service request webservice endpoint. Regarding the below document he's able to create message but MessageContent value looks different on postman and in the UI SR page

https://docs.oracle.com/en/cloud/saas/sales/r13-update17d/faaps/toc.htm

The message can be created with below URL and input.

https://XXXX-test.fa.em2.oraclecloud.com:443/crmRestApi/resources/11.13.18.05/serviceRequests/SR00000010XX/child/messages/

{
"MessageTypeCd": "ORA_SVC_CUSTOMER_ENTRY",
"StatusCd": "ORA_SVC_COMMITTED",
"MessageContent": "Test"
}

After the message is created, he queries the message with below URL.

https://XXXX-test.fa.em2.oraclecloud.com:443/crmRestApi/resources/11.13.18.05/serviceRequests/SR0000001001/child/messages/3000000014929XX/enclosure/MessageContent

The output is that:

"M�"

Why the message content shows different on the create input?

If the message is created normally, in UI, it will show ok but if created from Webservice, it shows the weird sign.

Upon checking in data base, I was able to find the message content to be the same value: M�


 

Solution

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Goal
Solution


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.