My Oracle Support Banner

Connecting Fabric Java-SDK via Squid Cache Proxy Server Gives "gRPC failure" Error (Doc ID 2571089.1)

Last updated on SEPTEMBER 13, 2021

Applies to:

Blockchain Platform Cloud Service - Version N/A to N/A
Information in this document applies to any platform.

Symptoms

Java SDK clients (v1.3) trying to connect to OBP instances via proxy  "Squid Cache: Version 3.5.20".
While making any queries/invocations, Java SDK clients receives below error:


Having in mind that chaincode invocations run over grpcs, please answer below queries:

- Confirm that Oracle cloud allows grpc connections through proxy? 
- Explain why we receive 503 errors?
- Suggest whether the proxy used ("Squid Cache: Version 3.5.20") is the cause of this issue?

Changes

 

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Changes
Cause
Solution
References


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.