My Oracle Support Banner

OCI: Repository ol7_developer_EPEL Needed By oci-utils Package (Doc ID 2715461.1)

Last updated on SEPTEMBER 30, 2020

Applies to:

Oracle Cloud Infrastructure - Version N/A to N/A [Release 1.0]
Linux x86-64 on Oracle Public Cloud

Goal

After disabling the ol7_developer_EPEL repository in a OCI Oracle Linux 7 instance, later attempts to install or update the package oci-utils via yum do not work correctly:

# yum update oci-utils
Loaded plugins: langpacks, ulninfo
Resolving Dependencies
--> Running transaction check
---> Package oci-utils.noarch 0:0.10.1-9.el7 will be updated
---> Package oci-utils.noarch 0:0.11.0-7.el7 will be an update
--> Processing Dependency: python3-sdnotify for package: oci-utils-0.11.0-7.el7.noarch
--> Processing Dependency: python3-daemon for package: oci-utils-0.11.0-7.el7.noarch
--> Running transaction check
---> Package python3-daemon.noarch 0:2.1.2-7.0.3.el7 will be installed
--> Processing Dependency: python36-docutils for package: python3-daemon-2.1.2-7.0.3.el7.noarch
--> Processing Dependency: python3-lockfile for package: python3-daemon-2.1.2-7.0.3.el7.noarch
---> Package python3-sdnotify.noarch 0:0.3.2-4.0.1.el7 will be installed
--> Running transaction check
---> Package python3-daemon.noarch 0:2.1.2-7.0.3.el7 will be installed
--> Processing Dependency: python36-docutils for package: python3-daemon-2.1.2-7.0.3.el7.noarch
---> Package python3-lockfile.noarch 1:0.11.0-13.0.1.el7 will be installed
--> Finished Dependency Resolution
Error: Package: python3-daemon-2.1.2-7.0.3.el7.noarch (ol7_developer_x86_64)
          Requires: python36-docutils
You could try using --skip-broken to work around the problem

 

Solution

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Goal
Solution


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.