My Oracle Support Banner

Error When Upgrading CEC Tookit, "error: Your local changes to the following files would be overwritten by merge: sites/bin/cec/cec.js" (Doc ID 2744506.1)

Last updated on APRIL 06, 2021

Applies to:

Content and Experience Cloud - Version N/A and later
Content and Experience Cloud Classic - Version 19.3.2 and later
Content and Experience Cloud Service - Version N/A and later
Information in this document applies to any platform.

Symptoms

Error when upgrading CEC Toolkit

Users receive the following error when attempting to git pull for the latest version of the cec toolkit.  

C:\cec-toolkit\content-and-experience-toolkit>git pull
remote: Enumerating objects: 17, done.
remote: Counting objects: 100% (17/17), done.
remote: Compressing objects: 100% (3/3), done.
remote: Total 17 (delta 13), reused 17 (delta 13), pack-reused 0
Unpacking objects: 100% (17/17), 2.19 KiB | 20.00 KiB/s, done.
From https://github.com/oracle/content-and-experience-toolkit
  050611f..9f202aa primary -> origin/primary
 * [new tag] 21.1.1a -> 21.1.1a
error: Your local changes to the following files would be overwritten by merge:
  sites/bin/cec/cec.js
Please commit your changes or stash them before you merge.
Aborting
Updating 

It should be noted that there was a recent upgrade to OCE 21.1.1; there were no issues with the install / upgrade.  The tool was no in use in this environment since the upgrade and there were no changes to cec.js. 

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Cause
Solution


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.