My Oracle Support Banner

Claims IC To Fetch Procedures For Procedure Groups Not Working Correctly (Doc ID 2750513.1)

Last updated on AUGUST 12, 2021

Applies to:

Oracle Insurance Claims Administration Cloud Service - Version NA and later
Information in this document applies to any platform.

Goal

Claims IC to fetch procedures for procedure groups not working correctly.

During testing of specialty mapping that below endpoint is not working if the procedure group parameter has leading zero

https://xxxx/cla-api/generic/proceduregroupdetails?q=procedureGroup.code.eq("054")
tried with '054' and 054 as well.

same works fine for 101
https://xxxx/cla-api/generic/proceduregroupdetails?q=procedureGroup.code.eq("101") - ran correctly

 

Steps to reproduce:

1.Setup a Procedure

2.Setup a Procedure GROUP (code should have leading zero, ex: 054)

3.Add the procedure (created in step 1) to the procedure group (created in step 2)

4.Run the below IP:

http://xxxx/api/generic/proceduregroupdetails?q=procedureGroup.code.eq("054")

 

Actual: The one with leading zero always returns 204 - No Content though there is associated procedure/s in the system, tried with no quotes, single quotes as well.

Expected: Claims IP to fetch procedures for procedure groups should work correctly. 

Solution

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Goal
Solution
References


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.