My Oracle Support Banner

ALL_XSC_SECURITY_CLASS View And Other XDB Views Owned By Sys Invalid After Catupgrd.sql Upgrading 9.2.0.8 To 11.2.0.1 (Doc ID 1080639.1)

Last updated on AUGUST 04, 2018

Applies to:

Oracle Server - Enterprise Edition - Version: 11.2.0.1.0 to 11.2.0.1.0 - Release: 11.2 to 11.2
Information in this document applies to any platform.

Symptoms

Upgrading an APPS database from 9.2.0.8.0 to 11.2.0.1
The dbua execution was ok.

For some other reason you ran catupgrd.sql script in this already upgraded database and that invalidated some XDB objects owned by SYS:

SYS ALL_XSC_SECURITY_CLASS VIEW
PUBLIC ALL_XSC_SECURITY_CLASS SYNONYM
SYS ALL_XSC_SECURITY_CLASS_STATUS VIEW
PUBLIC ALL_XSC_SECURITY_CLASS_STATUS SYNONYM
SYS ALL_XSC_SECURITY_CLASS_DEP VIEW
PUBLIC ALL_XSC_SECURITY_CLASS_DEP SYNONYM
SYS ALL_XSC_PRIVILEGE VIEW
PUBLIC ALL_XSC_PRIVILEGE SYNONYM
SYS ALL_XSC_AGGREGATE_PRIVILEGE VIEW
PUBLIC ALL_XSC_AGGREGATE_PRIVILEGE SYNONYM


Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.