Query With Ansi Join And Select For Update Fails With Ora-918 Error After Upgrade To 11.2 (Doc ID 1111459.1)

Last updated on MARCH 01, 2017

Applies to:

Oracle Server - Standard Edition - Version 11.2.0.1 to 11.2.0.1 [Release 11.2]
Information in this document applies to any platform.
***Checked for relevance on 19-Jun-2012***

Symptoms

After upgrading the database from 10.2.0.3 to 11.2.0.1 a query with an ansi join and a select for update started failing with an ORA-918 error indicating that a column is ambiguously defined.

Changes

Upgraded database to 11.2.0.1.

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms