My Oracle Support Banner

Caths.sql Fails With Warning: Package Created With Compilation Errors. (Doc ID 1276010.1)

Last updated on OCTOBER 24, 2019

Applies to:

Oracle Database - Enterprise Edition - Version 9.2.0.1 to 10.2.0.5 [Release 9.2 to 10.2]
Information in this document applies to any platform.
Oracle Database release 10.2.0.1, 10.2.0.2, 10.2.0.3, 10.2.0.4 and 10.2.0.5

Symptoms

After dropping and trying to recreate the HS catalog in an Oracle dataase release 10.2 using caths.sql  the script fails with:

Warning: Package created with compilation errors.

Changes

using PL/SQL native package compilation:
sho parameter plsql

NAME TYPE VALUE
------------------------------------ ----------- ------------------------------
plsql_ccflags                        string
plsql_code_type                   string      NATIVE
plsql_compiler_flags            string      NATIVE, NON_DEBUG
plsql_debug                         boolean  FALSE
plsql_native_library_dir        string
plsql_native_library_subdir_count integer 0
plsql_optimize_level integer 2
plsql_v2_compatibility boolean FALSE
plsql_warnings string DISABLE:ALL

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Changes
Cause
Solution


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.