Upgrade Standalone Grid Infrastructure from 11201 to 11202 fails with "OHASD is not running as privileged user" (Doc ID 1284876.1)

Last updated on OCTOBER 12, 2016

Applies to:

Oracle Database - Enterprise Edition - Version 11.2.0.1 and later
Information in this document applies to any platform.

Symptoms

o non-RAC Grid Infrastructure (aka Oracle Restart) install on Linux x86-64
o upgrading from 11.2.0.1 to 11.2.0.2
o while running  rootupgrade.sh the OHASD process fails to start with the following errors:

ohasd failed to start at /u01/app/oracle/product/11.2.0/grid/crs/install/roothas.pl line 325.
/u01/app/oracle/product/11.2.0/grid/perl/bin/perl -I/u01/app/oracle/product/11.2.0/grid/perl/lib -I/u01/app/oracle/product/11.2.0/grid/crs/install /u01/app/oracle/product/11.2.0/grid/crs/install/roothas.pl execution failed

The corresponding alert<node> log shows:

2011-08-21 18:18:13.749
[ohasd(8089)]CRS-0702:Oracle High Availability Service aborted due to failure to run as privileged user. Details at (:OHAS00102:) in /u01/app/oracle/product/11.2.0/grid/log/entdb-dt-a1d/ohasd/ohasd.log.

And the ohasd log shows:

2011-08-21 18:18:13.748: [ default][2877981168] Running mode check...
2011-08-21 18:18:13.749: [ default][2877981168] Created alert : (:OHAS00102:) : OHASD is not running as privileged user
2011-08-21 18:18:13.749: [ default][2877981168][PANIC] OHASD exiting: must be run as privileged user
2011-08-21 18:18:13.750: [ default][2877981168] Done.



Changes

Upgrade of standalone (non-RAC) Grid Infrastructure from 11.2.0.1.0 to 11.2.0.2.0

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms