My Oracle Support Banner

Actions For DST Updates When Upgrading To Or Applying The 11.2.0.3 Patchset (Doc ID 1358166.1)

Last updated on AUGUST 04, 2018

Applies to:

Oracle Database - Enterprise Edition - Version 8.1.7.4 to 11.2.0.3 [Release 8.1.7 to 11.2]
Oracle Database - Standard Edition - Version 8.1.7.4 to 11.2.0.3 [Release 8.1.7 to 11.2]
Information in this document applies to any platform.

Purpose

 To provide a step by step flow to determine if there are DST version implications when upgrading to 11.2.0.3 or applying the 11.2.0.3 patchset on a 11.2.0.1 or 11.2.0.2 database home.

The Oracle Java Virtual Machine (OJVM) also has DST information, but has no internal datatypes which store that information, hence this can be updated by simply applying the latest/newest OJVM DST patch.available.

Scope

These steps should be followed before
* applying 11.2.0.3 on an 11.2.0.2 or 11.2.0.1 database
* upgrading from 11.1.0.x , 10.2.0.x, 10.1.0.x , 9.2.0.x or 9.0.1.x version directly to 11.2.0.3 release.
The goal is to see what actions are needed on DST information before or after upgrading to 11.2.0.3
Used abbreviations:

TZ: TimeZone
TSTZ: TimeStamp with Time Zone
TSLTZ: TimeStamp with Local Time Zone
OJVM: Oracle Java Virtual Machine

Details

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Purpose
Scope
Details
 Things good to know:
 A) Applying 11.2.0.3 on 11.2.0.2 or 11.2.0.1
 A.1) The result is lower than 14 for all databases (typically 11)
 A.2) The result is 14 for all databases
 A.3) The result is higher than 14 for one or more databases:
 B)When Upgrading to 11.2.0.3 from 8i , 9i , 10g or 11.1.0.x
 B.1) check your current DST version on 9i, 10g or 11.1.0.x
 B.1a) When upgrading from 10.1.0.x , 10.2.0.x or 11.1.0.x to 11.2.0.3
 B.1b) When upgrading from 9.0.1.x or 9.2.0.x to 11.2.0.3:
 B.1c) When upgrading from 8.1.7 to 11.2.0.3:
 B.2) If your current timezone version is higher than DSTv14 when upgrading to 11.2.0.3 from 9.2.0.8, 10.1.0.5, 10.2.0.x. or 11.1.0.x:
 B.3) If your current timezone version is lower than 14 (typically 4) when upgrading to 11.2.0.3 from 9.2.0.8, 10.1.0.5, 10.2.0.x. or 11.1.0.x::
 B.3a) When upgrading from 9.0.1.x or 9.2.0.x to 11.2.0.3:
 B.3b) When upgrading from 10.1.0.x , 10.2.0.x or 11.1.0.x to 11.2.0.3:
 C) Do I also need to patch clients?
 D) What about TIMESTAMP WITH LOCAL TIME ZONE data?
 E) What if I want to go to a higher DST version than DSTv14 during the upgrade?
 F) Why is the DST version seen in registry$database sometimes different than from v$timezone_file ?
 G) When should I NOT update the DST version to DSTv14 after upgrading to 11.2.0.3?
 H) Do I NEED to update to DSTv14 after upgrading to 11.2.0.3?
References

My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.