RMAN backup to OSB failing: opening device /dev/obt0 failed - no dev resp (OB device driver) (Doc ID 1383448.1)

Last updated on OCTOBER 11, 2016

Applies to:

Oracle Secure Backup - Version 10.2.0.3 and later
Information in this document applies to any platform.

Symptoms

Following a server reboot, RMAN backups to OSB are now failing.


$ rman target /

Recovery Manager: Release 10.2.0.3.0 - Production on Mon Nov 14 12:50:38 2011

Copyright (c) 1982, 2005, Oracle.  All rights reserved.

connected to target database: PROD (DBID=1774891055)

RMAN> run {
allocate channel t1 type sbt trace 99;
backup datafile 1;
}2> 3> 4>

using target database control file instead of recovery catalog
RMAN-00571: ===========================================================
RMAN-00569: =============== ERROR MESSAGE STACK FOLLOWS ===============
RMAN-00571: ===========================================================
RMAN-03009: failure of allocate command on t1 channel at 11/14/2011 12:50:43
ORA-19554: error allocating device, device type: SBT_TAPE, device name:
ORA-27211: Failed to load Media Management Library
Additional information: 2

RMAN>

RMAN> RUN {
ALLOCATE CHANNEL t1 type 'SBT_TAPE' format '%U' trace 99
parms 'SBT_LIBRARY=/u01/app/oracle/backup/.lib.ibm64/libobk.so
ENV=(OB_MEDIA_FAMILY=OSB--DIARIO-MF)';
BACKUP datafile 1;
2> RELEASE CHANNEL t1;
}
3> 4> 5> 6> 7>
RMAN-00571: ===========================================================
RMAN-00569: =============== ERROR MESSAGE STACK FOLLOWS ===============
RMAN-00571: ===========================================================
RMAN-03009: failure of allocate command on t1 channel at 11/14/2011 12:51:05
ORA-19554: error allocating device, device type: SBT_TAPE, device name:
ORA-27211: Failed to load Media Management Library
Additional information: 2




From the OSB perspective, the device is not responding:


$ cat /var/tmp/obndmpdms.log
2011/10/26.09:38:07 [1466418] opening device /dev/obt0 failed - no dev resp (OB device driver)
2011/10/26.10:42:37 [1044562] opening device /dev/obt0 failed - no dev resp (OB device driver)


# /u01/app/oracle/backup/bin/obtool --user admin
Password:
ob> lsdev
drive tape_rmt0 in service
ob>
ob> dumpdev tape_rmt0
No errors have been logged for "tape_rmt0".
ob>
ob> mountdev --overwrite tape_rmt0
Error: can't mount volume in tape_rmt0 - no dev resp





Changes

Server Reboot

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms