My Oracle Support Banner

Dependency Problems While Installing MySQL Enterprise RPM Packages (Doc ID 1420514.1)

Last updated on DECEMBER 18, 2018

Applies to:

MySQL Server - Version 5.0 to 5.5 [Release 5.0 to 5.5]
Information in this document applies to any platform.

Symptoms

When installing MySQL RPM packages, you may encounter dependency errors such as the following while trying to remove existing packages provided by a Linux distribution.

error: Failed dependencies:
libmysqlclient.so.16()(64bit) is needed by (installed) postfix-2:2.6.6-2.1.el6_0.x86_64
libmysqlclient.so.16(libmysqlclient_16)(64bit) is needed by (installed) postfix-2:2.6.6-2.1.el6_0.x86_64
libmysqlclient_r.so.16()(64bit) is needed by (installed) qt-mysql-1:4.6.2-17.el6.x86_64
libmysqlclient_r.so.16(libmysqlclient_16)(64bit) is needed by (installed) qt-mysql-1:4.6.2-17.el6.x86_64
mysql-libs is needed by (installed) postfix-2:2.6.6-2.1.el6_0.x86_64

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Cause
Solution
References


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.