rootupgrade.sh Fails With "The cluvfy tool found some mandatory patches are not installed"

(Doc ID 1452184.1)

Last updated on OCTOBER 23, 2013

Applies to:

Oracle Database - Enterprise Edition - Version 11.2.0.3 and later
Information in this document applies to any platform.

Symptoms

Upgrading to 11gR2 Grid Infrastructure, rootupgrade.sh fails with the following:

cluvfy patch check failed, output is
Performing pre-checks for cluster services setup

The cluvfy tool found some mandatory patches are not installed.
These patches need to be installed before the upgrade can proceed.
The pre-upgrade checks failed, aborting the upgrade
/ocw/grid/11.2.0.3/perl/bin/perl -I/ocw/grid/11.2.0.3/perl/lib -I/ocw/grid/11.2.0.3/crs/install /ocw/grid/11.2.0.3/crs/install/rootcrs.pl execution failed
2012-04-09 10:13:36: Earlier version Oracle Grid Infrastructure is running
2012-04-09 10:13:36: Running as user oracle: /ocw/grid/11.2.0.3/bin/cluvfy stage -pre crsinst -n racnode1,racnode2 -upgrade -src_crshome /ocw/crs/11.1.0.7 -dest_crshome /ocw/grid/11.2.0.3 -dest_version 11.2.0.3.0 -_patch_only
2012-04-09 10:13:36: s_run_as_user2: Running /bin/su oracle -c ' /ocw/grid/11.2.0.3/bin/cluvfy stage -pre crsinst -n racnode1,racnode2 -upgrade -src_crshome /ocw/crs/11.1.0.7 -dest_crshome /ocw/grid/11.2.0.3 -dest_version 11.2.0.3.0 -_patch_only '
2012-04-09 10:14:24: Removing file /tmp/file0ZHiyf
2012-04-09 10:14:24: Successfully removed file: /tmp/file0ZHiyf
2012-04-09 10:14:24: /bin/su exited with rc=1

2012-04-09 10:14:24: cluvfy patch check failed, output is
 Performing pre-checks for cluster services setup

2012-04-09 10:14:24: The cluvfy tool found some mandatory patches are not installed.
2012-04-09 10:14:24: These patches need to be installed before the upgrade can proceed.

 

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms