My Oracle Support Banner

Unable To Execute PL/SQL ie Trigger With Db Link between 9.2 and 11g, Raises ORA-04052 (Doc ID 1471928.1)

Last updated on JULY 31, 2017

Applies to:

PL/SQL - Version 9.2.0.8 and later
Information in this document applies to any platform.
***Checked for relevance on 02-Dec-2013***

Symptoms

Attempting to use PL/SQL across a database link, specifically 9.2.0.8 to 11.2.0.3 through a trigger fails with:

ORA-04052: error occurred when looking up remote object %s%s%s%s%s

while stand-alone sql works fine over a database link.

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Cause
Solution
References


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.