Why Does OUI Attempts To Install ACFS/ADVM On Platforms Or OS Versions Where ACFS Is Not Supported? (Doc ID 1486574.1)

Last updated on MARCH 15, 2014

Applies to:

Oracle Database - Enterprise Edition - Version 11.2.0.2 and later
Information in this document applies to any platform.

Goal

Example:  SUSE SP2 is not listed in the following links, so 11.2 ACFS/ADVM is not supported for SUSE SP2:

    http://docs.oracle.com/cd/E11882_01/relnotes.112/e23558/toc.htm#CHDEGDFF
      Oracle® Database Release Notes
      11g Release 2 (11.2) for Linux
      Part Number E23558-07
      Chapter 3 - Unsupported Products

      OR

      <Note:1369107.1>


Therefore after Grid Infrastructue (GI) install, ACFS is registered in the OCR:

     $ cat /etc/SuSE-release
        SUSE Linux Enterprise Server 11 (x86_64)
        VERSION = 11
        PATCHLEVEL = 2

     $ acfsdriverstate -orahome /u001/app/11.2.0/grid supported
        ACFS-9459: ADVM/ACFS is not supported on this OS version: '3.0.13-0.27-default SP2'
        ACFS-9201: Not Supported

     Also 'crsctl stat res -t' from each node, lists the ACFS product, with a State of OFFLINE:

     HA Resource               Target    State
     ...
     ora.registry.acfs          ONLINE   OFFLINE
     ora.registry.acfs          ONLINE   OFFLINE
     ...

Why then, Oracle Universal Installer (OUI) attempts to install an Oracle product or feature on a platform or OS version where it is not supported?

Solution

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms