Unsupported: 11.2.0.1/11.2.0.2 GI root.sh Fails on OL6/RHEL6 with ohasd failed to start: Inappropriate ioctl for device (Doc ID 1557677.1)

Last updated on OCTOBER 27, 2015

Applies to:

Oracle Database - Enterprise Edition - Version 11.2.0.1 to 11.2.0.2.0 [Release 11.2]
Linux x86-64

Symptoms

This issue is specific to Grid Infrastructure installation on Linux 6 (or OL 6), the problem only happens for 11.2.0.1 or 11.2.0.2 installation. It could happen to both Grid Infrastructure or Oracle Restart (standalone Grid Infrastructure).

The message is taken from installing 11.2.0.1 Oracle restart on Linux 6, it fails at root.sh:

 ohasd failed to start: Inappropriate ioctl for device
2013-05-21 16:28:00: Appending to /etc/inittab.tmp:
2013-05-21 16:28:00: h1:35:respawn:/etc/init.d/init.ohasd run >/dev/null 2>&1 </dev/null

2013-05-21 16:28:00: Done updating /etc/inittab.tmp
2013-05-21 16:28:00: Saved /etc/inittab.crs
2013-05-21 16:28:00: Installed new /etc/inittab
2013-05-21 16:30:00: ohasd failed to start: Inappropriate ioctl for device
2013-05-21 16:30:00: ###### Begin DIE Stack Trace ######
2013-05-21 16:30:00: Package File Line Calling
2013-05-21 16:30:00: --------------- -------------------- ---- ----------
2013-05-21 16:30:00: 1: main roothas.pl 166 crsconfig_lib::dietrap
2013-05-21 16:30:00: 2: main roothas.pl 296 main::__ANON__
2013-05-21 16:30:00: ####### End DIE Stack Trace #######

 

Changes

New installation.

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms