Using ODP.NET through Mapping Layer Gives "Could not load file or assembly 'Oracle.DataAccess, Version=X10.1.0.301, Culture=neutral, PublicKeyToken=89b483f429c47342' or one of its dependencies. The system cannot find the file specified." (Doc ID 1559311.1)

Last updated on OCTOBER 10, 2016

Applies to:

Oracle Data Provider for .NET - Version 9.2.0.1 and later
Information in this document applies to any platform.
*** Checked for relevance on 5-Feb-2015 ***

Symptoms

Using an calling model like

.NET Application -> Mapping Layer -> ODP.NET

will end up with an error like

where the version number can vary - for example 2.112.1, 10.2.0.301 etc

Testing the mapping layer directly - i.e. by introducing a main() - will not raise the error - indicating that ODP.NET is installed correctly.

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms