My Oracle Support Banner

Installing Impala 1.0.1 Managed by Cloudera Manager On Oracle Big Data Appliance v2.1.*/v2.2.* (Doc ID 1612338.1)

Last updated on MARCH 04, 2014

Applies to:

Big Data Appliance Integrated Software - Version 2.1.1 to 2.2.1 [Release 2.1 to 2.2]
Linux x86-64

Purpose

The information provided gives the steps on how to configure Impala release 1.0.1 managed by Cloudera Manager on Oracle Big Data Appliance (BDA) prior to v2.3.1. The same steps can be followed on the 2.1.*/2.2.* release of BDA.

Starting with BDA V2.3.1 the required impala rpms are installed by default. If the Impala service will be managed by CM then on BDA V2.3.1 you can install Impala 1.1 or 1.0. On BDA V2.4 you can install Impala 1.2 or higher. The reason is that Version 1.2.* or higher of Impala requires Cloudera Manager (CM) 4.8 or higher and Cloudera Manager 4.8 is provided as part of BDA 2.4.

Scope

 The administrator of the Oracle Big Data Appliance.

Details

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Purpose
Scope
Details
 Overview
 Downloading Impala 1.0.1 RPMs
 Installing Impala 1.0.1 RPMs
 Adding Impala in Oracle Big Data Appliance through Cloudera Manager
 Prerequisites for Resolving Known Issues Prior to impala-shell Use
 Testing Impala Install with impala-shell
 Using Query Editor with Impala in Hue
 Removing Impala 1.0.1 from Cloudera Manager and the BDA
References

My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.