12c: Operr error tool (Doc ID 1640626.1)

Last updated on MAY 05, 2014

Applies to:

Oracle Database - Enterprise Edition - Version 12.1.0.1 to 12.1.0.1 [Release 12.1]
Information in this document applies to any platform.

Goal

operr is a utility for OPatch used to get probable causes and recommended actions for all OPatch error code.

When OPatch errors out with an error code, you can invoke operr on that error code to get a probable cause and recommended actions.

SYNTAX :- operr <opatch error code> [-f <message file>] [-version] [-jdk <JDK home>] [-jre <JRE home>]

 

opatch error code: the error code printed to the console when you invoke OPatch.


[message file]: this argument is optional. If you don’t specify the messagefile,OPatch will use the built-in message file bundled inside the Java package $ORACLE_HOME/OPatch/jlib/opatch.jar (package oracle/opatch/diag/operr.txt).
The message file is a file that contains probable causes and recommended actions for all OPatch error code. OPatch team also puts the latest message file on My Oracle Support. You can download the latest patch 16609471 that has the latest message file, and run operr with the “-f” option to retrieve latest probable causes and recommended actions.


[-version]:operr version” will print out the version of the operr utility {jdk] or [jre]: If there is no JRE or JDK in the Oracle Home, you can use these arguments to launch operr.

Solution

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms