My Oracle Support Banner

Actions For DST Updates When Upgrading To Or Applying The 12.1.0.2 Patchset (Doc ID 1665676.1)

Last updated on AUGUST 04, 2018

Applies to:

Oracle Database - Enterprise Edition - Version 8.1.7.4 to 12.1.0.2 [Release 8.1.7 to 12.1]
Oracle Database - Standard Edition - Version 8.1.7.4 to 12.1.0.2 [Release 8.1.7 to 12.1]
Information in this document applies to any platform.

Purpose

To provide a step by step flow to determine if there are DST version implications when upgrading to 12.1.0.2 .

The Oracle Java Virtual Machine (OJVM) also has DST information, but has no internal datatypes which store that information, hence this can be updated by simply applying the latest/newest OJVM DST patch available.

Scope

These steps should be followed before upgrading from 12.1.0.1, 11.2.0.x, 11.1.0.x , 10.2.0.x, 10.1.0.x , 9.2.0.x or 9.0.1.x version to 12.1.0.2 release.
The goal is to see what actions are needed on DST information before or after upgrading to 12.1.0.2
Used abbreviations:

TZ: TimeZone
TSTZ: TimeStamp with Time Zone
TSLTZ: TimeStamp with Local Time Zone
OJVM: Oracle Java Virtual Machine

Details

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Purpose
Scope
Details
 Things good to know:
 A) When Upgrading to 12.1.0.2 choose the relevant older Oracle RDBMS version:
 A.1) When upgrading from 10.2.0.5, 11.1.0.7, 11.2.0.2, 11.2.0.3, 11.2.0.4 or 12.1.0.1 to 12.1.0.2
 A.2) When upgrading from 11.2.0.1 to 12.1.0.2:
 A.3) When upgrading from 11.1.0.6 to 12.1.0.2:
 A.4) When upgrading from 10.2.0.1, 10.2.0.2, 10.2.0.3 or 10.2.0.4 to 12.1.0.2:
 A.5) When upgrading from 10gR1 (10.1.0.x) to 12.1.0.2:
 A.6) When upgrading from 9i (9.0.x or 9.2.0.x) to 12.1.0.2:
 A.7) When upgrading from 8.1.7 to 12.1.0.2:
 B) If your current timezone version is higher than DSTv18 when upgrading from 10.2.0.5, 11.1.0.7, 11.2.0.2, 11.2.0.3 , 11.2.0.4 or 12.1.0.1 to 12.1.0.2 :
 C) If your current timezone version is lower than 18 (typically 4, 11 or 14) when upgrading from 10.2.0.5, 11.1.0.7, 11.2.0.2, 11.2.0.3 , 11.2.0.4 or 12.1.0.1 to 12.1.0.2 :
 D) Do I also need to patch clients?
 E) What about TIMESTAMP WITH LOCAL TIME ZONE data?
 F) What if I want to go to a higher DST version than DSTv18 during the upgrade?
 G) Why is the DST version seen in registry$database sometimes different than from v$timezone_file ?
 H) When should I NOT update the DST version to DSTv18 after upgrading to 12.1.0.2?
 I) Do I NEED to update to DSTv18 after upgrading to 12.1.0.2?
References

My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.