Installation on OL6 Fails with Error KERNEL OF PROPER VERSION IS NOT FOUND Expected = "2.6.39"

(Doc ID 1924549.1)

Last updated on FEBRUARY 02, 2017

Applies to:

Oracle Database - Enterprise Edition - Version to [Release 12.1]
Linux x86-64


 Installation of Database on Linux 64bit OL 6 machine .The CVU checks shows the following error in the installation logs:

INFO: ****************** CVU Error logs ******************
INFO: FINE: [Task.perform:493]  
INFO: FINE: [Task.perform:514]  
INFO: FINE: [VerificationCommand.execute:297]  
Output: '<CV_VAL>2.6.32-358.11.1.el6.x86_64
</CV_VAL><CV_VRES>0</CV_VRES><CV_LOG>Exectask: OS version retrieval
-getosver </CV_INITCMD><CV_CMD>/bin/uname -r</CV_CMD><CV_CMDOUT>
INFO: ERROR: [Result.addErrorDescription:624]  Kernel of proper version is
not found on node "sfddds202" [Expected = "2.6.39" ; Found =
INFO: FINE: [Task.perform:594]  
TaskKernelVersion:OS Kernel
          ERRORMSG(sfddds202): Kernel of proper version is not found on node
"sfddds202" [Expected = "2.6.39" ; Found = "2.6.32-358.11.1.el6.x86_64"]

Using  Oracle linux 6 with red hat compatible option and customer system has kernal version is 2.6.32-358 which higher version than 2.6.32-71
but it's looking at UEK rather than Red Hat Compatible kernel.

OL6 can support both types (UEK or RH compatible) of kernel.  But the reference pre-req xml does not have any conditional reference data for kernel
version depending on the kernel type.


Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms