After Upgrade, the Listener Fails to Start with "Could not load program tnslsnr" (Doc ID 1953720.1)

Last updated on SEPTEMBER 27, 2016

Applies to:

Oracle Net Services - Version 11.2.0.4 and later
IBM AIX on POWER Systems (64-bit)

Symptoms

 After an upgrade, the listener fails to start the the following errors (note the 'symbol' errors may be different)

Could not load program tnslsnr:
Symbol resolution failed for tnslsnr because:
       Symbol __start (number 345) is not exported from dependent
         module /usr/lib/libpthreads.a[shr_xpg5_64.o].
       Symbol nlstdgbl (number 346) is not exported from dependent
         module /usr/lib/libpthreads.a[shr_xpg5_64.o].
Examine .loader section symbols with the 'dump -Tv' command.
TNS-12547: TNS:lost contact
TNS-12560: TNS:protocol adapter error
 TNS-00517: Lost contact
  IBM/AIX RISC System/6000 Error: 32: Broken pipe

Changes

This issue arose during an upgrade of Oracle Software.

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms