Datapatch Fails with Error “Could not load module libclntshcore.so.” (Doc ID 1963110.1)

Last updated on JANUARY 27, 2015

Applies to:

Oracle Database - Standard Edition - Version 12.1.0.1 and later
Information in this document applies to any platform.

Symptoms

After applying PSU in 12c Environment,Datapatch fails with below Error -

/u01/app/oracle/product/12.1.0.1/OPatch $ ./datapatch -verbose
Can’t load ‘/u01/app/oracle/product/12.1.0.1/perl/lib/site_perl/5.14.1/aix-thread-multi-64all/auto/DBD/Oracle/Oracle.so’ for module DBD::Oracle: Could not load module /u01/app/oracle/product/12.1.0.1/perl/lib/site_perl/5.14.1/aix-thread-multi-64all/auto/DBD/Oracle/Oracle.so.
Dependent module libclntshcore.so could not be loaded.
Could not load module libclntshcore.so.
System error: No such file or directory
Could not load module /u01/app/oracle/product/12.1.0.1/perl/lib/site_perl/5.14.1/aix-thread-multi-64all/auto/DBD/Oracle/Oracle.so.
Dependent module /u01/app/oracle/product/12.1.0.1/perl/lib/site_perl/5.14.1/aix-thread-multi-64all/auto/DBD/Oracle/Oracle.so could not be loaded. at /u01/app/oracle/product/12.1.0.1/perl/lib/5.14.1/aix-thread-multi-64all/DynaLoader.pm line 190.
at /u01/app/oracle/product/12.1.0.1/sqlpatch/sqlpatch.pl line 49
Compilation failed in require at /u01/app/oracle/product/12.1.0.1/sqlpatch/sqlpatch.pl line 49.
BEGIN failed–compilation aborted at /u01/app/oracle/product/12.1.0.1/sqlpatch/sqlpatch.pl line 49.

 

  

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms