BDA Upgrade to BDA 4.1 Fails at Step 6 with "Could not start Service[odi-agent]: Execution of '/sbin/service odi-agent start' returned 1:" (Doc ID 1965628.1)

Last updated on JANUARY 30, 2015

Applies to:

Big Data Appliance Integrated Software - Version 4.1.0 and later
Linux x86-64

Symptoms

BDA upgrade to 4.1 may fail at step 6 Installing BDC Packages with:

INFO: Installing BDA software on cluster. This will take some time ...
INFO: Puppet script successfully sent to node bdanode01
...
INFO: Puppet script successfully sent to node bdanode0n
ERROR: Puppet script either timed out or ended with error on one or more nodes
ERROR: Nodes that failed are: , bdanode04
...
ERROR: Puppet agent run on node bdanode04 had errors. List of errors follows

************************************
Error [26172]: (//bdanode04.us.oracle.com/Puppet) [FAILED]
Error [26172]: (//bdanode04.us.oracle.com/Puppet) [FAILED]
Error [26172]: (//bdanode04.us.oracle.com//Stage[main]/Odi::Odiupgrade/Service[odi-agent]/ensure)
change from stopped to running failed:
Could not start Service[odi-agent]: Execution of '/sbin/service odi-agent start' returned 1: Port 20910 is being used by another process
Error [26172]: (//bdanode04.us.oracle.com//Stage[main]/Odi::Odiupgrade/Service[odi-agent]/ensure) [FAILED]

1. On Node 4 manually trying to start the odi-agent fails with:



Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms