On Oracle Big Appliance CDH Cluster Upgrade, Linux Kernel is Not Updated (Doc ID 1982970.1)

Last updated on OCTOBER 11, 2016

Applies to:

Big Data Appliance Integrated Software - Version 3.0.1 to 4.2.0 [Release 3.0 to 4.2]
Linux x86-64

Symptoms

Upgrading Oracle Big Data Appliance CDH Cluster with OL6 OS from 4.0 to 4.1. But the same issue can occur on any release of BDA upgrade up to 4.2.0.

During upgrade , step3 is supposed to perform a Linux kernel upgrade.

Say for example for OL6 from 6.4 to 6.5 followed by a reboot(optional) .  But after the upgrade is completed the Linux Kernel is not upgraded to 6.5. And also Cluster Validation checks performed as part of the upgrade indicate many rpms are not upgraded as well

 ERROR: Required package version expect-5.44.1.15-4.el6.x86_64 is not supported in release 4.1.0
  ERROR: Required package version gnutls-2.8.5-10.el6_4.2.x86_64 is not supported in release 4.1.0
 ERROR: Required package version iptables-1.4.7-9.el6.x86_64 is not supported in release 4.1.0
 ERROR: Required package version krb5-libs-1.10.3-10.el6_4.6.x86_64 is not supported in release 4.1.0
 ERROR: Required package version krb5-workstation-1.10.3-10.el6_4.6.x86_64 is not supported in release 4.1.0
 ERROR: Required package version libstdc++-4.4.7-3.el6.x86_64 is not supported in release 4.1.0
  ERROR: Required package version libstdc++-4.4.7-3.el6.i686 is not supported in release 4.1.0
 ERROR: Required package version mdadm-3.2.5-4.el6_4.2.x86_64 is not supported in release 4.1.0
 ERROR: Required package version mstflint-1.4-6.el6.x86_64 is not supported in release 4.1.0
 ERROR: Required package version openssh-server-5.3p1-84.1.el6.x86_64 is not supported in release 4.1.0
 ERROR: Required package version perl-5.10.1-131.el6_4.x86_64 is not supported in release 4.1.0
 ERROR: Required package version python-2.6.6-37.el6_4.x86_64 is not supported in release 4.1.0
 ERROR: Required package version rpm-4.8.0-32.el6.x86_64 is not supported in release 4.1.0
 ERROR: Required package version ruby-1.8.7.352-12.el6_4.x86_64 is not supported in release 4.1.0
  ERROR: Required package version sudo-1.8.6p3-7.el6.x86_64 is not supported in release 4.1.0
  ERROR: Required package version zsh-4.3.10-5.el6.x86_64 is not supported in release 4.1.0
 ERROR: Big Data Appliance failed software validation checks

 

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms