ORA-600 [17023] Errors After Setting Edition Property to EBR Enabled database (Doc ID 2064516.1)

Last updated on OCTOBER 27, 2015

Applies to:

Oracle Database - Enterprise Edition - Version 11.2.0.4 to 12.1.0.2 [Release 11.2 to 12.1]
Information in this document applies to any platform.

Symptoms

Setting the edition property in the application (websphere having Oracle JDBC) to a different version on a EBR enabled database report with the following error in the alert log:

ORA-00600: internal error code, arguments: [17023], [0x18158ACA0], [0], [], [], [], [], [], [], [], [], []


The trace file shows characteristics like:

----- Current SQL Statement for this session (sql_id=cnmbppcpdznax) -----

ALTER PACKAGE "DLS"."PKG_CCTS_DLS_SEARCH" COMPILE BODY REUSE SETTINGS 

----- Call Stack Trace -----

... kglpur kqlvld kglgob kgldpo0 kgldpo kgldon pkloud phnnrl_name_resolve_by_loading phnr_resolve_by_loading ph2o_get_cands ph2o_overload_diana ph2op1 ph2stm ph2sms ph2blo ph2obl ph2sbo ph2itm ph2its ph2blo ph2obl ph2uni ph2dr2 ph2drv phpsem phpcmp pcicmp0 kkxcmp0 rpiswu2 kkxcmp kkpalt opiexe opiosq0 opiosq opiodr rpidrus skgmstack rpiswu2 rpidrv rpisplu kqlvld kglgob kgiinb pfri7_inst_body_common pfri3_inst_body pfrrun plsql_run ...

 
Packages are verified valid in the database.

Changes

Set the edition property in the application (websphere having Oracle JDBC) to a different version, e.g.

oracle.jdbc.editionName=v2

 

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms