YUM update from 12.1.2.1.1 to 12.1.2.1.3 fails during post installation phase due to conflicting cracklib rpm (Doc ID 2085434.1)

Last updated on SEPTEMBER 20, 2016

Applies to:

Oracle Exadata Storage Server Software - Version 12.1.2.1.1 and later
Information in this document applies to any platform.
rpm cracklib-2.8.9-3.3.i386 of 32 bit does not clean up during yum update and it fails during final phase of patching.

Symptoms

 Check /var/log/cellos/dbnodeupdate.log for below error
-----------------------------------------------
 Transaction Summary
    ====================
    Install       7 Package(s)
    Upgrade     185 Package(s)
    
    Total download size: 1.2 G
    Downloading Packages:
    --------------------------------------------------------------------------------
    Total                                           529 MB/s | 1.2 GB     00:02     
    Running rpm_check_debug
    ERROR with rpm_check_debug vs depsolve:
    python(abi) = 2.4 is needed by (installed) cracklib-2.8.9-3.3.i386
    ** Found 8 pre-existing rpmdb problem(s), 'yum check' output follows:
    cracklib-2.8.9-3.3.i386 has missing requires of python(abi) = ('0', '2.4', None)
    cracklib-2.8.16-4.el6.x86_64 is a duplicate with cracklib-2.8.9-3.3.i386
    exadata-sun-computenode-exact-12.1.2.1.1.150316.2-1.x86_64 has missing requires of config(irqbalance) = ('2', '1.0.4', '9.0.3.el6_5')
    exadata-sun-computenode-exact-12.1.2.1.1.150316.2-1.x86_64 has missing requires of irqbalance = ('2', '1.0.4', '9.0.3.el6_5')
    exadata-sun-computenode-exact-12.1.2.1.1.150316.2-1.x86_64 has missing requires of irqbalance(x86-64) = ('2', '1.0.4', '9.0.3.el6_5')
    fuse-2.8.3-4.0.2.el6.x86_64 has missing requires of kernel >= ('0', '2.6.14', None)
    2:irqbalance-1.0.7-5.0.1.el6.x86_64 has missing requires of kernel >= ('0', '2.6.32', '358.2.1')
    perl-BSD-Resource-1.28-1.fc6.1.x86_64 has missing requires of perl(:MODULE_COMPAT_5.8.8)
    Your transaction was saved, rerun it with: yum load-transaction /tmp/yum_save_tx-2015-12-02-23-13ozZdYR.yumtx

.
    ERROR with rpm_check_debug vs depsolve:
   python(abi) = 2.4 is needed by (installed) cracklib-2.8.9-3.3.i386              >>>>>>>>>>>>>Since 32 bit cracklib-2.8.9-3.3.i386 is already installed and not cleaning up to get installed 64 bit.
   ** Found 8 pre-existing rpmdb problem(s), 'yum check' output follows:
   cracklib-2.8.9-3.3.i386 has missing requires of python(abi) = ('0', '2.4', None)
   cracklib-2.8.16-4.el6.x86_64 is a duplicate with cracklib-2.8.9-3.3.i386      >>>>>>>>>>>>>>It is not allowing to install 64 bit of cracklib-2.8.16-4.el6.x86_64

Changes

 YUM update from 12.1.2.1.1 to 12.1.2.1.3 

Can also occur on 12.1.2.1.2 to 12.1.2.1.3.

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms