Upgrade to BDA V4.4 Fails with Patch_fimage/Exec[post_upgrade_script] Due to Error Downloading Java (Doc ID 2101985.1)

Last updated on FEBRUARY 04, 2016

Applies to:

Big Data Appliance Integrated Software - Version 4.4.0 and later
Linux x86-64

Symptoms

The upgrade to BDA V4.4 fails prior to patching the factor image with:

INFO: Patching factory image. This will take some time ...
INFO: Puppet script successfully sent to node bdanode01
INFO: Pinging puppet agents .........
ERROR: Puppet agent run on node bdanode01 had errors. List of errors follows

************************************
Error [13045]: (//bdanode01.example.com//Stage[main]/Miscsetup::Patch_fimage/Exec[post_upgrade_script]/returns)
change from notrun to 0 failed: /opt/oracle/bda/network/post_upgrade103 &>
/opt/oracle/BDAMammoth/bdaconfig/tmp/post_upgrade_script_1454268088.out returned 2 instead of one of [0]
************************************

 1. On Node 1, /opt/oracle/BDAMammoth/bdaconfig/tmp/post_upgrade_script_1454268088.out contains:

Downloading Packages:
http://bdanode01.example.com/bda/RPMS/x86_64/jdk-8u66-linux-x64.rpm: [Errno 14]
PYCURL ERROR 7 - "couldn't connect to host"
Trying other mirror.
...
Error Downloading Packages:
2000:jdk1.8.0_66-1.8.0_66-fcs.x86_64: failure: RPMS/x86_64/jdk-8u66-linux-x64.rpm from bda:
[Errno 256] No more mirrors to try.
...
sed: can't read /usr/java/default/jre/lib/security/java.security: No such file or directory

2. Checking the cluster shows that the java package is not installed on Node 1.

a) /usr/java/default/jre/lib/security/java.security is not on Node 1: 

 

 

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms