My Oracle Support Banner

Replication to Tape is Failing due to OSB Jobs are Failing with the Status "Pending Resource Availability" (Doc ID 2112171.1)

Last updated on OCTOBER 27, 2019

Applies to:

Zero Data Loss Recovery Appliance Software - Version 12.1.1.1.1 and later
Information in this document applies to any platform.

Symptoms

Replication to tape is failing due the osb jobs are  failing with the status "pending resource availability"

-  The following is the status of the OSB Jobs :

# obtool lsj
Job ID   Sched time     Contents                                                                       State
-------  ---------------- ------------------------------------------------------------- ---------------------------------------
1         02/24.00:00    dataset OSB-CATALOG-DS                                         processed; host backup(s) scheduled
1.1      02/24.00:00    backup osbadminvip                                                 pending resource availability
2         02/25.00:00    dataset OSB-CATALOG-DS                                         processed; host backup(s) scheduled
2.1      02/25.00:00    backup osbadminvip                                                 pending resource availability

-  The transcript of the OSB Job is showing the following error for each tape drive :

1.1: 1: 2016/02/24.14:41:43 ______________________________________________________________________
1.1: 1: 2016/02/24.14:41:43
1.1: 2: 2016/02/24.14:41:43 Transcript for job 1.1 running on osbadminvip
1.1: 2: 2016/02/24.14:41:43
1.1: 3: 2016/02/24.14:41:44 (amh) qdv__automount_in_mh entered
1.1: 4: 2016/02/24.14:41:44 (amh) qdv__automount_in_mh 0_3_1_13 at 2016/02/24.14:41:44, flags 0x100
1.1: 5: 2016/02/24.14:41:44 (amh) mount volume options list contains:
1.1: 6: 2016/02/24.14:41:44 (amh) vtype 3 (app), vid (null), vs_create 0, family dm03dbadm01_fs, retain (null), size 0, mediainfo 2, scratch 0
1.1: 7: 2016/02/24.14:41:44 (amh) can't open qlm connection - drive not found in library database (library manager)
1.1: 8: 2016/02/24.14:41:44 ---
1.1: 9: 2016/02/24.14:41:44 No volume could be found in robot0 (for drive 0_3_1_13) to use for job 1.1.
1.1: 10: 2016/02/24.14:41:44 The problem using 0_3_1_13 and the volume it contains, if any, is
1.1: 11: 2016/02/24.14:41:44 drive not found in library database (library manager)

 

-   The tape library and the devices are in service :

# obtool lsdev

library robot0 in service
drive 0,1,11 0_0_1_11 in service
drive 1,1,13 0_1_1_13 in service
drive 2,1,13 0_2_1_13 in service
drive 3,1,13 0_3_1_13 in service

-  The load and unload of the volume is failing with the same error :

ob> loadvol --drive 0_0_1_11 001845
Error: unable to open qlm connection - drive not found in library database
ob> loadvol --drive 0_0_1_11 1
Error: unable to open qlm connection - drive not found in library database

-  Firewall feature is not enabled on this ACSLS server.

Changes

 This is a new installation.

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Changes
Cause
Solution
References


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.