After Upgrade to BDA V4.5 the Cluster Verification Checks Report RPM Errors and "DB_RUNRECOVERY: Fatal error, run database recovery"

(Doc ID 2188370.1)

Last updated on APRIL 26, 2018

Applies to:

Big Data Appliance Integrated Software - Version 4.5.0 and later
Linux x86-64

Symptoms

Note, any time the rpm database is corrupted during rpm install, these symptoms can occur.  This happens at various stages of upgrade or install and may be noticed during those Mammoth actions or after those Mammoth actions when running the final cluster verification checks.   The main symptom is output like:

find: '/etc/modprobe.d/bda.conf': No such file or directory
rpmdb: Thread/process 2376/140709861353376 failed: Thread died in Berkeley DB library
error: db3 error(-30974) from dbenv->failchk: DB_RUNRECOVERY: Fatal error, run database recovery
error: cannot open Packages index using db3 - (-30974)
error: cannot open Packages database in /var/lib/rpm
CRITICAL:yum.main:

Error: rpmdb open failed
rpmdb: Thread/process 2376/140709861353376 failed: Thread died in Berkeley DB library
error: db3 error(-30974) from dbenv->failchk: DB_RUNRECOVERY: Fatal error, run database recovery
error: cannot open Packages index using db3 - (-30974)
error: cannot open Packages database in /var/lib/rpm
CRITICAL:yum.main:

 

1. The symptoms after upgrade when running the final cluster verification checks are like below:

a) The cluster verification checks report that Linux packages are not supported like:

bdanode01: ERROR: Required package version bash-4.1.2-29.el6.0.1.x86_64 is not supported in release 4.5.0
bdanode01: ERROR: Required package version coreutils-8.4-37.0.1.el6.x86_64 is not supported in release 4.5.0
bdanode01: ERROR: Required package version dnsmasq-2.48-14.el6.x86_64 is not supported in release 4.5.0
bdanode01: ERROR: Required package version ibacm-1.0.9-0.git49af5a8.el6.x86_64 is not supported in release 4.5.0
bdanode01: ERROR: Required package version iptables-1.4.7-14.0.1.el6.x86_64 is not supported in release 4.5.0
bdanode01: ERROR: Required package version libstdc++-4.4.7-11.el6.x86_64 is not supported in release 4.5.0
bdanode01: ERROR: Required package version libstdc++-4.4.7-11.el6.i686 is not supported in release 4.5.0
bdanode01: ERROR: Required package version mstflint-3.6.0-0.1_1.8.g7d4dede.el6.x86_64 is not supported in release 4.5.0
bdanode01: ERROR: Required package version ncurses-5.7-3.20090208.el6.x86_64 is not supported in release 4.5.0
bdanode01: ERROR: Required package version perl-5.10.1-136.el6_6.1.x86_64 is not supported in release 4.5.0
bdanode01: ERROR: Required package version python-2.6.6-52.el6.x86_64 is not supported in release 4.5.0
bdanode01: ERROR: Required package version rpm-4.8.0-38.el6_6.x86_64 is not supported in release 4.5.0
bdanode01: ERROR: Required package version zsh-4.3.10-9.el6.x86_64 is not supported in release 4.5.0
bdanode01: ERROR: Required package version librdmacm-1.0.18.1-1.el6.x86_64 is not supported in release 4.5.0
bdanode01: ERROR: Big Data Appliance failed software validation checks

b) And then when  following the MOS document:  On Oracle Big Appliance CDH Cluster Upgrade, Linux Kernel is Not Updated (Doc ID 1982970.1) pu.err shows:


2. During Mammoth upgrade when Mammoth hangs and the errors raised when running something like: "yum search openssl" are like above.

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms