Oracle Cloud - Hitting ORA-28357 When Trying To Create a 12.2 Pluggable database From An Application Root Container (Doc ID 2228673.1)

Last updated on FEBRUARY 17, 2017

Applies to:

Oracle Database as a Service - Version N/A and later
Advanced Networking Option - Version 12cBETA3 and later
Information in this document applies to any platform.

Symptoms

In database 12.2 version,

Creating Pluggable (PDB) database for Application container database, failed with

SQL> CREATE PLUGGABLE DATABASE apps_pdb
2 ADMIN USER admin IDENTIFIED BY oracle_4U
3 ROLES=(CONNECT)
4 CREATE_FILE_DEST='/u02/app/oracle/oradata/apps_pdb/';
CREATE PLUGGABLE DATABASE apps_pdb
*
ERROR at line 1:
ORA-28357: password required to open the wallet

SQL> CREATE PLUGGABLE DATABASE apps_pdb
2 ADMIN USER admin IDENTIFIED BY oracle_4U
3 ROLES=(CONNECT)
4 CREATE_FILE_DEST='/u02/app/oracle/oradata/apps_pdb/'
5 KEYSTORE IDENTIFIED BY "Piece#1";
KEYSTORE IDENTIFIED BY "Piece#1"
*
ERROR at line 5:
ORA-00922: missing or invalid option

 

 

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms