MySQL Keyring Plugin Installation Problem: "[ERROR] unknown variable 'early-plugin-load=keyring_file.so'" or "[ERROR] unknown variable 'early-plugin-load=keyring_okv.so'" (Doc ID 2253303.1)

Last updated on APRIL 09, 2017

Applies to:

MySQL Server - Version 5.5 and later
Information in this document applies to any platform.

Symptoms

In MySQL Server 5.5, 5.6, and 5.7.11 and earlier the following error occurs in the MySQL error log when attempting to enable the keyring_file or keyring_okv plugin using the early-plugin-load configuration option in the MySQL configuration file (my.cnf/my.ini):

 

Changes

Attempted to enable the keyring_file or keyring_okv plugin.

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms