My Oracle Support Banner

Diskgroup not mounting after upgrade to 12.2: ORA-59303: The attribute compatible.asm should be 11.2.0.2.0 or higher. (Doc ID 2256559.1)

Last updated on AUGUST 04, 2018

Applies to:

Oracle Database - Enterprise Edition - Version 12.2.0.1 and later
Information in this document applies to any platform.

Symptoms

Upgrading Grid Infrastructure to 12.2.0.1, rootupgrade.sh was successful on node1 but some diskgroups not mounting despite no error in root script log, mounting the diskgroup manually fails: 

SQL> alter diskgroup ORA_DATA mount;
alter diskgroup ORA_DATA mount
*
ERROR at line 1:
ORA-15032: not all alterations performed
ORA-59303: The attribute compatible.asm (10.1.0.0.0) of the diskgroup being mounted should be 11.2.0.2.0 or higher.
ORA-15221: ASM operation requires compatible.asm of 11.1.0.0.0 or higher



Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Cause
Solution
References


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.