ODA: Upgrade to Failed Due to Package kernel-uek-headers Was Removed

(Doc ID 2294031.1)

Last updated on AUGUST 07, 2017

Applies to:

Oracle Database Appliance Software - Version to [Release 12.1]
Information in this document applies to any platform.


During ODA upgrade precheck, command "oakcli validate –c ol6upgrade –prechecks" fails:

ERROR: 2017-05-17 17:36:02: Check for additional RPMs failed

INFO: 2017-05-17 17:36:02: Checking for expected RPMs installed
INFO: 2017-05-17 17:36:03: Please install the RPM : perl-RPC-XML.noarch
INFO: 2017-05-17 17:36:03: Please install the RPM : kernel-uek-headers.x86_64 <<<< the package was not installed.
ERROR: 2017-05-17 17:36:03: Check for expected RPMs failed
WARNING: Node is not ready for ol6upgrade



 Upgrade to ODA


Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms