opatchauto fails with Error - "OPatch Failing Minimum Version Not Met" even though latest Opatch version is in use

(Doc ID 2294499.1)

Last updated on OCTOBER 02, 2017

Applies to:

Oracle Database - Enterprise Edition - Version 11.2.0.4 and later
Information in this document applies to any platform.

Symptoms

Applying GI PSU fails with the following error message:

2017-06-01 17:11:46: Starting Clusterware Patch Setup
Using configuration parameter file: /local/grid/oragrid/product/11.2.0.4/grid/crs/install/crsconfig_params
The opatch minimum version check for patch /local/grid/oragrid/media/PSU/23274134/23054359 failed for /local/grid/oragrid/product/11.2.0.4/grid
The opatch minimum version check for patch /local/grid/oragrid/media/PSU/23274134/23054319 failed for /local/grid/oragrid/product/11.2.0.4/grid
The opatch minimum version check for patch /local/grid/oragrid/media/PSU/23274134/22502505 failed for /local/grid/oragrid/product/11.2.0.4/grid
Opatch version check failed for oracle home /local/grid/oragrid/product/11.2.0.4/grid
Opatch version check failed
ERROR: update the opatch version for the failed homes and retry

opatch auto failed.
[root@racnode2 grid]#

However the opatch version is at the latest:

u@h: ./opatch version
OPatch Version: 11.2.0.3.16

OPatch succeeded.
QA u@h: pwd
/local/grid/oragrid/product/11.2.0.4/grid/OPatch

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms