datapatch fails with error:"PLS-00201: identifier ‘DBMS_LOCK.REQUEST’ must be declared" (Doc ID 2303983.1)

Last updated on SEPTEMBER 06, 2017

Applies to:

Oracle Database - Enterprise Edition - Version 12.1.0.2 and later
Information in this document applies to any platform.

Symptoms

The following Error message is reported during ./datapatch execution.

Changes

While applying patch at database level using datapatch.

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms