Oracle Restart: Startup Fails with Error - CRS-0807:Cluster Ready Service aborted due to failure to check version compatibility

(Doc ID 2311147.1)

Last updated on OCTOBER 03, 2017

Applies to:

Oracle Database - Enterprise Edition - Version 11.2.0.1 and later
Information in this document applies to any platform.

Symptoms

Oracle Restart startup fails with below errors:

Cluster alert log

2017-09-13 10:24:20.527
[ohasd(21428)]CRS-0807:Cluster Ready Service aborted due to failure to check version compatibility. Details at (:OHAS00115:) in /u01/app/grid/product/11.2.0/grid/log/<node1>/ohasd/ohasd.log.
2017-09-13 10:24:22.007
[ohasd(21467)]CRS-2112:The OLR service started on node <node1>.
2017-09-13 10:24:22.012
[ohasd(21467)]CRS-0807:Cluster Ready Service aborted due to failure to check version compatibility. Details at (:OHAS00115:) in /u01/app/grid/product/11.2.0/grid/log/<node1>/ohasd/ohasd.log.
2017-09-13 10:24:23.499
[ohasd(21506)]CRS-2112:The OLR service started on node <node1>.
2017-09-13 10:24:23.504
[ohasd(21506)]CRS-0807:Cluster Ready Service aborted due to failure to check version compatibility. Details at (:OHAS00115:) in /u01/app/grid/product/11.2.0/grid/log/<node1>/ohasd/ohasd.log.
[client(21562)]CRS-10001:CRS-10132: No msg for has:crs-10132 [10][60]

ohasd log

2017-09-13 12:52:00.452: [ default][1] OHASD Daemon Starting. Command string :restart
2017-09-13 12:52:00.462: [ default][1] Initializing OLR
2017-09-13 12:52:00.472: [ OCRRAW][1]proprioo: for disk 0 (/u01/app/grid/product/11.2.0.4/grid_2/cdata/localhost/node1.olr), id match (1), total id sets, (1) need recover (0), my votes (0), total votes (0), commit_lsn (6), lsn (6)
2017-09-13 12:52:00.472: [ OCRRAW][1]proprioo: my id set: (1240419658, 1028247821, 0, 0, 0)
2017-09-13 12:52:00.472: [ OCRRAW][1]proprioo: 1st set: (1240419658, 1028247821, 0, 0, 0)
2017-09-13 12:52:00.472: [ OCRRAW][1]proprioo: 2nd set: (0, 0, 0, 0, 0)
2017-09-13 12:52:00.522: [ CRSOCR][1] OCR context init CACHE Level: 102696070
2017-09-13 12:52:00.522: [ default][1] Checking version compatibility...
2017-09-13 12:52:00.524: [ default][1]clsvactversion:4: Retrieving Active Version from local storage.
2017-09-13 12:52:00.526: [ default][1] Exiting, Release Version [ 186647296 ][ 11.2.0.3.0 ] less than Software Version [ 186647552 ][ 11.2.0.4.0 ]
2017-09-13 12:52:00.527: [ default][1] Created alert : (:OHAS00115:) : Version Compatibility check failed
2017-09-13 12:52:00.527: [ default][1][PANIC] OHASD exiting: Version Compatibility check failed
2017-09-13 12:52:00.527: [ default][1] Done.

 

Changes

Failed upgrade from 11.2.0.3 to 11.2.0.4 and reverted back to 11.2.0.3 incompletely

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms