Step 7 of Mammoth 4.10 Upgrade Fails to Complete Spark 2 Service Creation Instead Raises "Command failed to run because service Spark 2 has invalid configuration."

(Doc ID 2329911.1)

Last updated on NOVEMBER 21, 2017

Applies to:

Big Data Appliance Integrated Software - Version 4.10.0 and later
Linux x86-64

Symptoms



Step 7 of an upgrade to Mammoth 4.10 fails to complete creation of the Spark 2 service and instead fails with:

...
INFO: Time spent in step 7 StartHadoopServices is 2844 seconds.
==================================================================================
INFO: Command 169661 finished
ERROR: Operation failed
ERROR: Result Message is: Command failed to run because service Spark 2 has invalid configuration. Review

and correct its configuration. First error: Service spark2_on_yarn has 0 History Servers. Spark 2 requires

at least 1 History Server.
ERROR: Errors getting client configuration files from the cluster
ERROR: Cannot continue with operation
...

 

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms