My Oracle Support Banner

How to Resolve "ERROR: Required package jdk<version> is not valid : S.5....T. /usr/java/<version>/jre/lib/security/cacerts" (Doc ID 2339399.1)

Last updated on DECEMBER 17, 2017

Applies to:

Big Data Appliance Integrated Software - Version 4.0 and later
Linux x86-64

Goal

Running bdacheckcluster returns the following error about cacerts on one or more cluster nodes:

ERROR: Required package jdk<version> is not valid : S.5....T. /usr/java/<version>/jre/lib/security/cacerts


This error occurs because the cacerts installed by default has been modified in some way. Any changes to the original /usr/java/<version>/jre/lib/security/cacerts will be flagged as an error because this is a system-owned file that is not intended for modification by the end-user. cacerts contains the default CA information shipped with the JDK installed on the cluster and is intended to be static and unmodified.

User specific changes should not be made to /usr/java/<version>/jre/lib/security/cacerts. Any custom changes should be made in /usr/java/<version>/jre/lib/security/jssecacerts

Solution

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.