Grid Infrastructure Installation Hang at Nodes Listing Step with Nothing Displayed

(Doc ID 2340422.1)

Last updated on DECEMBER 21, 2017

Applies to:

Oracle Database - Enterprise Edition - Version 12.1.0.2 and later
Information in this document applies to any platform.

Symptoms

New installation of Grid Infrastructure (GI) 12.1.0.2. The progress was stuck at step 6 on listing of nodes, there is nothing displayed in the OUI (Oracle Universal Installer) .

Installation log showed (installActions<date time stamp>.log inside <central inventory location>/logs):

  
INFO: Found Vendor Clusterware. Fetching Cluster Configuration
INFO: Executing [/tmp/OraInstall2017-09-19_01-11-16PM/ext/bin/lsnodes]     <<<<<<<<<<<============= executes lsnodes
with environment variables {TERM=vt100, ORACLE_HOME=/oracle/app/grid, JAVA_HOME=, SHLVL=2, XFILESEARCHPATH=/usr/dt/app-defaults/%L/Dt, ORACLE_BASE=/oracle/app/gridbase, MAIL=/var/spool/mail/grid, PWD=/oracle/grid, HOSTNAME=rachost1, LOGNAME=grid, CVS_RSH=ssh, G_BROKEN_FILENAMES=1, _=/oracle/grid/install/.oui, QTDIR=/usr/lib64/qt-3.3, NLSPATH=/usr/dt/lib/nls/msg/%L/%N.cat, SHELL=/bin/bash, HISTSIZE=1000, CLASSPATH=, PATH=/usr/bin:/usr/ccs/bin:/oracle/app/grid/OPatch:/oracle/app/grid/bin:/usr/lib64/qt-3.3/bin:/usr/local/bin:/bin:/usr/bin:/usr/local/sbin:/usr/sbin:/sbin:/home/grid/bin:/oracle/grid/install, QTINC=/usr/lib64/qt-3.3/include, LC_ALL=, DISPLAY=10.9.x.188:0.0, USER=grid, QTLIB=/usr/lib64/qt-3.3/lib, HOME=/home/grid, HISTCONTROL=ignoredups, LESSOPEN=||/usr/bin/lesspipe.sh %s, ORACLE_SID=+ASM1, LS_COLORS=rs=0:di=01;34:ln=01;36:mh=00:pi=40;33:so=01;35:do=01;35:bd=40;33;01:cd=40;33;01:or=40;31;01:mi=01;05;37;41:su=37;41:sg=30;43:ca=30;41:tw=30;42:ow=34;42:st=37;44:ex=01;32:*.tar=01;31:*.tgz=01;31:*.arj=01;31:*.taz=01;31:*.lzh=01;31:*.lzma=01;31:*.tlz=01;31:*.txz=01;31:*.zip=01;31:*.z=01;31:*.Z=01;31:*.dz=01;31:*.gz=01;31:*.lz=01;31:*.xz=01;31:*.bz2=01;31:*.tbz=01;31:*.tbz2=01;31:*.bz=01;31:*.tz=01;31:*.deb=01;31:*.rpm=01;31:*.jar=01;31:*.rar=01;31:*.ace=01;31:*.zoo=01;31:*.cpio=01;31:*.7z=01;31:*.rz=01;31:*.jpg=01;35:*.jpeg=01;35:*.gif=01;35:*.bmp=01;35:*.pbm=01;35:*.pgm=01;35:*.ppm=01;35:*.tga=01;35:*.xbm=01;35:*.xpm=01;35:*.tif=01;35:*.tiff=01;35:*.png=01;35:*.svg=01;35:*.svgz=01;35:*.mng=01;35:*.pcx=01;35:*.mov=01;35:*.mpg=01;35:*.mpeg=01;35:*.m2v=01;35:*.mkv=01;35:*.ogm=01;35:*.mp4=01;35:*.m4v=01;35:*.mp4v=01;35:*.vob=01;35:*.qt=01;35:*.nuv=01;35:*.wmv=01;35:*.asf=01;35:*.rm=01;35:*.rmvb=01;35:*.flc=01;35:*.avi=01;35:*.fli=01;35:*.flv=01;35:*.gl=01;35:*.dl=01;35:*.xcf=01;35:*.xwd=01;35:*.yuv=01;35:*.cgm=01;35:*.emf=01;35:*.axv=01;35:*.anx=01;35:*.ogv=01;35:*.ogx=01;35:*.aac=01;36:*.au=01;36:*.flac=01;36:*.mid=01;36:*.midi=01;36:*.mka=01;36:*.mp3=01;36:*.mpc=01;36:*.ogg=01;36:*.ra=01;36:*.wav=01;36:*.axa=01;36:*.oga=01;36:*.spx=01;36:*.xspf=01;36:, NLS_LANG=AMERICAN_AMERICA.ZHS16GBK, SSH_ASKPASS=/usr/libexec/openssh/gnome-ssh-askpass, LANG=en_US.UTF-8}
INFO: Starting Output Reader Threads for process /tmp/OraInstall2017-09-19_01-11-16PM/ext/bin/lsnodes
INFO: The process /tmp/OraInstall2017-09-19_01-11-16PM/ext/bin/lsnodes exited with code 1     <<<<<<<<<<<=============  lsnodes doesn't get results.
INFO: Waiting for output processor threads to exit.
 

Manual execution of 'lsnodes' command displayed:

 

Changes

Environment having installation of Veritas Cluster, but with some installation errors or wrong configurations.

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms