MySQL Utilities or Connector/Python Error: SSL: WRONG_VERSION_NUMBER

(Doc ID 2357115.1)

Last updated on MAY 15, 2018

Applies to:

MySQL Connectors - Version 2.1 and later
MySQL Utilities - Version 1.5.2 and later
Information in this document applies to any platform.

Symptoms

When trying to connect to MySQL Server using MySQL Connector/Python or some program using MySQL Connector/Python (for example MySQL Utilities) with SSL enabled, the following error occurs:

 

Changes

The issue may start after changing the tls_version option in MySQL Server or enabling SSL for the connection.

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms